We were very excited when HTML tables were introduced back in Netscape 1.2. Tables are a way to display and organize charts and data. They were most commonly used in financial or database spreadsheets because they provided defined columns and rows. The HTML engineers who created tables for the Web did not predict that developers would use tables to align images, not just to display text and numbers. Tables have, however, become the standard method used by designers to position and anchor content to Web pages. You'll learn about both uses for tables: a formatting device for data, and a layout device for custom positioning of images.

This chapter shows you how to create custom tables, insert rows and columns, come up with color schemes, and handle formatting and sorting tasks. You will also learn how to use tables to align and position images. Tables are a critical item in your Web design toolbox, and Dreamweaver MX gives you great control and techniques for mastering them. Towards the end of this chapter, we show you two table tricks: one for creating custom table borders, and another for making rounded table corners. Don't worry, the fun doesn't stop there; you will get to work with tables some more in Chapter 8, "Layout."
What Is a Table?

A table is a highly versatile feature in HTML. It can be useful for organizing data or positioning images. What does a table look like under the hood of Dreamweaver MX? It is comprised of a combination of HTML tags.

![A table in the browser.](image)

Here's the HTML for the table above. Tables always begin with a `<table>` tag. The width and border elements are attributes of the `<table>` tag. `<tr>` stands for table row, and `<td>` stands for table data.
A table contains rows, columns, and cells. If these terms are unfamiliar to you, this diagram should help.
Changing the Border of a Table

This first exercise helps you build your table formatting skills on a premade table. It also alerts you to a common HTML problem relating to empty table cells. You see, even if a table cell is empty, you have to put something in it to preserve the table formatting. That “something” can be a single-pixel transparent GIF, which is a small image file that has been set to be fully transparent, or invisible. It serves as a placeholder to keep the table formatting from collapsing with empty cells. You’ll learn how to add a transparent GIF in a few moments, once you get going with this exercise.

1. Copy chap_07 from the H•O•T CD-ROM to your hard drive. Define your site for Chapter 7 using the chap_07 folder as the local root folder. If you need a refresher on this process, visit Exercise 1 in Chapter 3, “Site Control.”

2. Open tableformat.html. The dotted lines that you see around each cell are just table border guides, and will not show up inside the browser.
3. Press **F12** to preview this file in your Web browser. Notice how the dotted lines don’t appear in the browser? In this file, the **border** setting was changed to **0** in order to make the formatting guides disappear, because Dreamweaver MX uses a default setting of **1** for table borders. The results of this change are visible only in the browser, not in the authoring environment of Dreamweaver MX. Next you’ll learn how to control the weight of the lines with the **border** property.

4. Return to Dreamweaver MX and select the entire table. You can do this by using the **Tag Selector** at the bottom left of the document window. Click anywhere inside the table. You should see the word `<table>` appear as a Tag Selector. Click the `<table>` element in the Tag Selector, and the entire table should become selected. With the table selected, in the **Property Inspector**, enter **Border: 1** and then press **Return/Enter**.
5. Press F12 to preview the results. See how the border value affected the appearance? This is one of the many controls that you have over the appearance of tables.

Note: Some browsers display the cell underneath Room # in a different way from the other table cells. In every other row there is content, but the cell without content looks different, or “bloated” because it is empty. The following steps will show you how to correct this problem.
6. In Dreamweaver MX, click inside the cell below the Room # cell (column 2, row 2). Choose Insert > Image, browse to shim.gif located inside the chap_07 folder, and click Open. Be careful to deselect the image after you insert it. If you press Return or Enter with it selected, it will disappear!

The file that you just inserted (shim.gif), contains a single-pixel transparent GIF, which is invisible to your end user. By placing it inside the empty table cell, you fool the browser into thinking there is content, even though your audience will never see that content. The sole purpose of inserting the graphic is to fix the appearance of the empty table cell.
7. Save the changes to the border. Press F12 to preview the results. See, no more funky pixels, Mom! The empty cell looks like every other cell, which is just the way it should look! Return to Dreamweaver MX and leave this document open for Exercise 2.

**NOTE | What Is a Transparent GIF?**

The GIF file format supports a feature called transparency, which is a term for a mask. Transparency makes it possible to specify areas in a GIF graphic to disappear in a Web browser. A single-pixel transparent GIF is a graphic that contains only a single pixel that has been instructed to disappear. You can create transparent GIF files in Fireworks, Photoshop, ImageReady, or a host of other graphics applications. Methods for making them vary in each program, so consult the user manual of whichever graphics application you own. If you like, you can store the file shim.gif for Web projects other than this book, and that way you will always have a single-pixel transparent GIF on hand.

**Note:** “Shim” is a term used in carpentry to hold things in place. You may name your single-pixel transparent GIF anything you like. “Shim” was just a name we chose.
2. Sorting the Table

In version 2.0, Macromedia introduced the capability to sort the content of tables both alphabetically and numerically in Dreamweaver MX. Before this feature existed, if you wanted to sort a table, you had to copy and paste each row or column manually. Thankfully, sorting table content is only a simple dialog box away.

1. The document `tableformat.html` should still be open. If not, go ahead and open it again.

2. Make sure that the table is selected and choose Commands > Sort Table. The Sort Table dialog box will open.

3. Change the settings to Sort By: Column 3, Order: Alphabetically Ascending. Click OK.

Notice that the file has been sorted differently from when you first opened it? The third column is now in alphabetical order. You can arrange table contents through this kind of command. Try doing this manually, and you’ll really appreciate this feature!
4. Save the file and keep it open for the next exercise.

The Sort Table Dialog Box

The **Sort Table** dialog box has a variety of options to help you modify the appearance of tables. See the chart below for an explanation of all its features:

<table>
<thead>
<tr>
<th>Sorting Features</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sort By</strong></td>
<td>Use this option to select which column you would like to use to sort the table.</td>
</tr>
<tr>
<td><strong>Order</strong></td>
<td>Use these two pull-down menus to choose Alphabetically or Numerically and Ascending or Descending.</td>
</tr>
<tr>
<td><strong>Then By</strong></td>
<td>Use this option to sort multiple columns in your table.</td>
</tr>
<tr>
<td><strong>Options: Sort Includes First Row</strong></td>
<td>If this box is checked, the first row in your table will be sorted. This option is off by default because most often the first row is used as a header for the table.</td>
</tr>
<tr>
<td><strong>Sort THEAD Rows (If Any):</strong></td>
<td>If this box is checked, all the rows in the table’s <code>&lt;thead&gt;</code> section (if any) will be sorted using the same criteria as the body rows.</td>
</tr>
<tr>
<td><strong>Sort TFOOT Rows (If Any):</strong></td>
<td>If this box is checked, all the rows in the table’s <code>&lt;tfoot&gt;</code> section (if any) will be sorted using the same criteria as the body rows.</td>
</tr>
<tr>
<td><strong>Options: Keep TR Attributes With Sorted Row</strong></td>
<td>If this box is checked, and a row is moved around due to sorting, all the attributes for that row will also move (e.g., color, font, etc.). <code>&lt;tr&gt;</code> stands for table row in HTML.</td>
</tr>
</tbody>
</table>
3. **Changing the Color Scheme**

Next on the list of table building skills is learning how to apply color formatting. This exercise shows off Dreamweaver MX's color-picking features for tables. Dreamweaver MX offers a variety of ways to get the job done. When it comes to coloring your tables, you may use Dreamweaver MX's automatic color features or set whatever custom colors you desire.

In this exercise, you will learn how to manually apply color to the background of tables, columns, rows, and cells by using the Property Inspector.

1. With `tableformat.html` still open from the previous exercise, select the `<table>` tag in the Tag Selector.
2. In the **Property Inspector**, click on the **Bg Color** box for the table and select white `#FFFFFF` from the **color cube**. The background color of the table changes.

3. Starting at the upper-left corner of the table, click and drag across the top row to select that entire row. Notice that the lower-left portion of the **Property Inspector** displays properties for the selected row.
4. In the **Property Inspector**, click the **Bg** color box and choose gray **#CCCCCC** from the color cube.

Here's what your table looks like now. You can color table columns and individual cells in much the same way.
5. Click inside the **first cell** in row 1 and drag down to select the **first column**. In the **Property Inspector**, click on the **Bg** color cube for the column and pick gray **#999999** from the color cube.

6. **Save** and **close** this file, you won’t need it any longer.

The table should now look like this.
The Format Table Command

But wait there’s more! Dreamweaver MX provides yet another way to customize your table’s color settings. The Format Table command is quick and easy to use; plus, it is great if you have trouble with or plain don’t like choosing colors. By choosing **Commands > Format Table**, you can open the **Format Table** dialog box.

![Format Table dialog box](image)

The Format Table dialog box gives you access to a bunch of preset color themes that can be applied to your tables. As you click through the various themes, notice how the table preview in the middle changes so you can preview that theme. These color combinations are part of Dreamweaver MX and can be applied to any table. Additionally, if you want, you can customize the color theme by clicking on a **Row Colors** box and selecting a color from the picker.
Creating and Modifying a Table

This exercise shows you how to create your own table from scratch and how to modify it. You will learn to work with a combination of the Insert Table object, the Modify > Table menu, and the Property Inspector. You won’t be building a finished page yet. Instead, you’ll have a chance to explore many of the different table options first.

1. Create a new document and save it as firsttable.html.

2. Enter Title: My First Table. Click the Insert Table object in the Common tab in the Insert panel or choose Insert > Table. The Insert Table dialog box will appear.

3. Make sure your settings match the settings above, then click OK.
The Insert Table dialog box’s default settings result in a table that is three rows high and three columns wide.

4. Select the left column by clicking inside the top-left cell and dragging down to the bottom row with your mouse button still depressed. Don’t worry, it’s not sad. ;-)

5. Choose Modify > Table > Merge Cells. This will result in a table with three columns, with the left column made of only one cell and the other two columns containing three rows of cells.

6. Select the middle row by clicking inside the left-middle cell and dragging over to the right-middle cell while leaving your mouse button depressed.
7. In the **Property Inspector**, click the **Merge Cells** button. This achieves the same effect as the **Modify** menu did in Step 5. As with many things in Dreamweaver MX, there are multiple ways to accomplish the same task. We prefer to use the **Property Inspector** to merge cells, though you may prefer to use the **Modify** menu method.

Just as you can merge cells in rows and columns, you can also add and delete entire rows and columns. However, selecting rows and columns can be tricky at times. For example, to select the column on the far left, you will find that you can no longer click and drag inside it because now it is only a single cell.

8. Put your cursor inside the left cell and click the `<td>` element on the **Tag Selector** at the bottom of the document (remember, `<td>` stands for table data). In the **Property Inspector**, click the **Split Cell** button. This brings up the **Split Cell** dialog box. Enter 3, if it’s not already entered, and make sure the **Rows** radio button is selected, then click **OK**.
7. Tables | Dreamweaver MX H•O•T

You just added back to this table the three cells that you merged in Step 5. See how flexible this table editor is?

9. To delete the left column completely, select it again and choose Edit > Cut. The shortcut keys for this are Ctrl+X (Windows) and Cmd+X (Mac). You can delete rows or columns by selecting them and cutting them out at any time.

10. Add a new row by clicking inside the upper-right cell and choosing Modify > Table > Insert Rows or Columns. Select Insert: Rows, Number of Rows: 1, and Where: Below the Selection. Click OK.

11. Here are the results of that action. You can also select other options, of course. Dreamweaver MX offers a lot of flexibility when it comes to formatting tables, which you'll likely find useful for the variety of table-related tasks that will arise over the course of your future Web-design projects. Save and close the file.
NOTE | Contextual Table Menus

Time and again, Dreamweaver MX lets you accomplish the same task in many different ways. For example, Exercise 4 showed you how to merge and split cells by using the Modify > Table menu or the Property Inspector. Alternately, you could select the column and Ctrl+click (Mac) or right-click (Windows) to access the contextual menu. There you will find a handy list of everything you’d ever want to do to a table.

You can use any of three ways to access this same information (Property Inspector, Modify menu, or contextual menu), depending on your preference.
5. **Aligning Images and Text with Tables**

Many people use tables to align images and text because they offer the ability to position artwork freely on a page. This next exercise shows you how to work with a page layout and modify the alignment through adjusting the height and width of table rows and columns.

1. Open bodycopy.html. Press F12. This is a text file that has no table formatting. Resize the browser window and watch how the width of the text within the document extends to the width of the browser. This is default alignment behavior, and the problem with it is that it can create very wide layouts on large monitors.

Most design experts agree that column widths should be limited in order to make reading text easier. You don’t see books that are 21 inches across with text stretching side-to-side. That’s because it’s hard for people to read lines of text that extend more than 3–4 inches across the screen. In order to create a narrower column, you will need to learn how to create a table with fixed-pixel widths.

2. Return to Dreamweaver MX. Create a new document and save this file in the chap_07 folder as align.html.
3. Choose **Modify > Page Properties** and enter **Title: Alignment with Tables**. Set the **Background** color to **#FFFFCC**, the **Text** color to **#000000**, the **Links** color to **#990000**, the **Visited Links** color to **#660000**, and the **Active Links** color to **#FF0000**. Click **Browse** to the right of the **Background Image** field and browse to **about_bg.jpg**. Click **Open**. You will be returned to the Page Properties dialog box. Click **OK**.

4. Choose **Insert > Table** and change the settings to **Rows: 2, Columns: 3, Width: 600 Pixels** (make sure you change this to Pixels, not Percent), and **Border: 0**. Click **OK**.
The result of these settings should look like this. You are laying down the framework for a fixed-pixel table that is suitable for aligning objects.

5. Choose Window > bodycopy.html (located at the bottom of the Window menu, which lists all the open documents). If for some reason bodycopy.html is not open, go ahead and open it from the Site window (F8).
6. Select and copy just the text that contains the Welcome statement. The image above shows you the text that should be selected.

7. Choose Window > align.html to bring forth the align.html document. Click inside column 2, row 1 and paste the text into that cell.
8. Switch back to the bodycopy.html document by choosing Window > bodycopy.html. Note: If you are using Windows and have your document window maximized, you could go back and forth between these two documents by clicking on the small tabs in the lower-left corner of each document window. Select and copy the first paragraph. Switch back to the document with the table in it by choosing Window > align.html. Click inside column 2, row 2 and paste the text into that cell. The image above shows what your page should look like at this point.

9. Switch between the two documents, using the Window menu, to copy and paste the second paragraph into column 3, row 2 of the table, as shown above. Close bodycopy.html. You’re finished with copying and pasting.

Notice that the top of column 2, row 2 does not align with the top of column 3, row 2? This is an example of default table formatting, which vertically centers the text in a table cell unless otherwise instructed. In order to fix this, you’ll need to adjust the table-alignment settings. The next step shows you how.
10. Click anywhere in the second row of the table. Click the `<tr>` tag in the **Tag Selector** to select the entire second row. Change the **Property Inspector's Vert** setting to **Top**. As you can see, this corrects the irregular alignment, but it also collapses the empty cell on the far left.

As you now know, empty cells in Dreamweaver MX and in browsers are certainly problematic, aren't they? The only solution is to insert a transparent GIF again, which you'll do in the following step.

11. If your rulers aren't visible, choose **View > Rulers > Show**. The rulers help you see the page's pixel dimensions.
12. Click inside the cell with the Welcome statement and press Shift+Tab. This will move your cursor into the collapsed cell. Choose Insert > Image, and browse to shim.gif, then click Open. The shim.gif will be selected, and you should see its settings inside the Property Inspector. Hint: If the shim.gif accidentally gets deselected, click inside its table cell and select the <img> element in the Tag Selector to reselect it. In the Property Inspector, enter W: 220. This should stretch the single-pixel GIF to hold the left-hand cell's dimension open.
13. Press **F12** to preview the results. This layout is starting to look good, but the space between the table cells feels a little cramped, doesn’t it?

14. Return to Dreamweaver MX and select the table by clicking anywhere inside it and choosing the `<table>` element inside the **Tag Selector**. In the **Property Inspector**, enter **CellSpace: 10**. As you will see, **CellSpace** controls the amount of space between cells. Press **F12** to preview the results.
Here are the results of changing the CellSpace attribute. The change is subtle, but it is different. If you want to experiment further with this file, try changing the dimensions of the shim.gif or the CellSpace or CellPad settings. You are in total control over the alignment of this page. By leaving the rulers turned on, you can get a better idea of what values to enter into the settings.

15. **Save** and **close** all the open documents before you begin the next exercise.
NOTE | Using Rulers

Rulers in Dreamweaver MX are helpful for getting a sense of scale. You can access rulers by choosing View > Rulers > Show.

NOTE | Fixed Pixels Versus Percentages in Tables

You can size your tables in two ways: by percentages or by pixels. A percentage-based table will stretch with the width of the browser, meaning that its size will vary depending on the size of the browser window. If you specify that a table uses a width of 75%, for example, it will stretch to fill three-fourths of the horizontal space regardless of the browser window size. This can be a great thing in some cases, but not in others. When you want to restrict the size of a table, regardless of the browser window size, pixel-based tables are the way to go. When you want the table to stretch to the size of the browser window, percentage-based tables are best. To complicate matters, it’s possible to nest a pixel-based table inside a percentage-based table or vice versa. By the time you’ve finished the exercises in this chapter, you will have some concrete examples as to why and when to choose which type of table, and how to combine the two for more complex formatting.
NOTE | CellPad Versus CellSpace

Using CellPad and CellSpace settings alters the amount of space between table cells. CellPad adds room inside the cell, whereas CellSpace adds to the space between cells. When used with table borders set to 0, CellSpace and/or CellPad achieve the identical result, by interjecting more space between the data and the edge of each cell.

The top table uses neither CellPad nor CellSpace, the middle table uses a CellPad setting of 10, and the bottom table uses a CellSpace setting of 10.

With colored table cells, the differences between CellPad (middle) and CellSpace (bottom) are more noticeable.
6. **Percentage-Based Table Alignment**

In the last exercise, you worked with a table that was fixed at 600 pixels. When you want to control your alignment precisely, fixed pixels are the way to go. There’s another way to achieve alignment with tables that is based on percentages. This next exercise uses percentage-based tables to ensure that the page elements will be centered on any size browser window.

1. Create a new document and save it into the *chap_07* folder and name it *center.html*.

2. Choose *Insert > Table* and change the settings to **Rows: 1**, **Columns: 1**, **Width: 100 Percent**, and **Border: 1**. For this exercise to work, it’s imperative that the width be set to Percent and not Pixels. Click *OK*. 
3. Select the `<table>` tag at the bottom of the document and change the **Property Inspector's** height setting (**H**) to **100%**. The Property Inspector's width setting (**W**) should already be set to **100%**. Press **F12** to preview this page in a browser.

Note: When you press F12 to preview this page right now, you can move the browser window size around, and you'll see the table stretch. What's happening? You specified that the width and height of this table would fill 100% of the browser's shape, regardless of its size. This is critical to the success of this exercise, because you are now going to align an image to this table, and the image will be aligned in relationship to the size of the browser, regardless of its shape.
4. Return to Dreamweaver MX. Click inside the giant table cell. Choose Insert > Image, browse to bonsai_symbol.jpg, and click Open.

5. In the Tag Selector, click on the `<td>` tag to select the table cell, and then in the Property Inspector, click the Align Center button. The image will pop into the center of the large table.
6. Press **F12** to preview and try stretching the browser to different positions. No matter how you set the browser window, this image will always be perfectly centered!

This is just one example of percentage-based table alignment. You could center an image to a pixel-based table, but because the table wouldn’t stretch to the size of the browser window, the image would center to the table’s shape, not the browser’s shape.

7. To finish the effect, return to Dreamweaver MX. Select the table by clicking inside it and highlighting the `<table>` **Tag Selector**. Change the **Property Inspector Border** setting to **0**. This will turn off the border.

8. Choose **Modify > Page Properties**, enter **Background: #FFFFCC**, and click **OK**.
9. Press **F12** to see the results. People who view this page will never know you used a table, yet the image will always be centered.

What's so great about hiding the table from viewers? Because you've just created a layout that is centered regardless of the size or shape of the browser window, and people who view this page won't be distracted by a table border at the edge of the browser screen.

10. Return to Dreamweaver MX. **Save** and **close** this file.
If you’ve looked around the Web much, you’ve probably noticed that tables are sometimes used to assemble multiple images so that they look like a single image. Why would anyone want to do this? Tables can ensure that artwork stays aligned and grouped, whereas HTML without tables can be subject to movement depending on the size of the browser window. This exercise shows you how to reassemble multiple images into a pixel-based table so that they won’t be misaligned.

1. Open `navbar1.html`. Notice the gaps between each of the images? This can be the result of putting images next to each other without a table.

2. Press `F12` to preview this document, then make your browser window smaller. Notice how the row of images gets disrupted? By placing them inside a table, they will become grouped, and won’t be able to move around like this.
3. Return to Dreamweaver MX. Click each image once (don’t double-click!), and you’ll see its dimensions inside the Property Inspector. You have six images, which are each 100 pixels wide. Multiplying 6 by 100 gives you 600, so you’ll need to create a 600-pixel-wide table in order to assemble these as one seamless-looking image.

4. Position your cursor after the last image and press Return or Enter, so your insertion cursor appears below the images on the screen and on the left.

5. Choose Insert > Table and change the settings to Rows: 1, Columns: 6, Width: 600 Pixels (not Percent!), and Border: 0. Click OK.

6. Click inside the far-left bottom cell, and choose Insert > Image. Browse to navbar1.gif inside the chap_07 folder and click Open. The table formatting between cells has shifted, but the image is now inside the appropriate cell.

7. Once you insert all the other images into the appropriate cells, the table should appear like this. The names of the files, from left to right, are navbar1.gif, navbar2.gif, navbar3.gif, navbar4.gif, navbar5.gif, and navbar6.gif.
8. To get rid of the gaps between the cells, select the entire table by clicking inside any cell and selecting the `<table>` Tag Selector. Once you've selected it, change the Property Inspector setting to read `CellPad: 0` and `CellSpace: 0`. The table will come together seamlessly.

9. Press F12 to preview your seamless table. Now that is what a navigation bar ought to look like!

10. Save this file and leave it open for the next exercise.
Combining Pixels and Percentages

This next exercise demonstrates how to combine a pixel-accurate table, like the one you just created in Exercise 7, with a percentage-based table like you created in Exercise 6. Why would this be important? Let’s say that you had a navigation bar, like the one you just built, that you wanted to be center aligned regardless of whether it was seen on a small or large monitor. Combining the last two techniques lets you do just that.

1. Create a new document and save it into the chap_07 folder and name it navbar2.html.

2. Choose Insert > Table and change the settings to Rows: 1, Columns: 1, Width: 100 Percent (not Pixels!), and Border: 0. Click OK. By using Percent for width, the table will always be horizontally centered on the page.

3. Return to navbar1.html (use the Window menu and look at the bottom to locate it) and select the bottom table. Remember that you can click anywhere in the table to access the Tag Selector in order to select it. With the table selected, choose Edit > Copy.

4. Now switch over to navbar2.html and click inside the centered table. Choose Edit > Paste.
5. Select the table that you just pasted. Again, if you click inside it you can use the `<table>` Tag Selector to select it. Notice there are two `<table>` tags in the Tag Selector now. This happens because you have one table nested inside another.

6. With the nested (navigation bar) table selected, change the Property Inspector Align setting to Center.

7. Preview in the browser (F12), and you should see that the navigation bar remains centered regardless of how wide you drag your browser window out. Congratulations again, you've just made a nested table using a combination of pixels and percentages. Sounds impressive, but even better than that—it's useful!

8. Return to Dreamweaver MX. Save and close the navbar1.html and navbar2.html files.
Inserting Tab-Delimited Data

As you just learned, creating tables from scratch can be quite a chore. So anything that helps streamline the process is a dream. Dreamweaver MX gives you the ability to easily insert delimited text files. This is great for people who use Excel and other office applications, because now it's simple to get that data into Dreamweaver MX. This exercise shows you how to import a delimited text file into a table.

9. Inserting Tab-Delimited Data

1. Open import.html. This is just a blank file that we created for you. Click the Tabular Data object in the Insert panel to open the Import Tabular Data dialog box.

2. Click Browse and navigate to tabdelimited.txt from the chap_07 folder. Click OK to select that file.
Import Tabular Data Settings

You won’t be changing most of the default settings in this exercise, but you should know what those options mean. Here’s a handy chart that explains what you can do in the Import Tabular Data dialog box.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data File</td>
<td>Use this option to browse to the delimited file on your hard drive.</td>
</tr>
<tr>
<td>Delimiter</td>
<td>This option specifies the type of delimiter used in the imported file, such as tabs or commas.</td>
</tr>
<tr>
<td>Table Width: Fit to Data</td>
<td>This option will create a table large enough to fit the data in the imported file.</td>
</tr>
<tr>
<td>Table Width: Set</td>
<td>This option lets you specify how wide to make the table that holds the imported data. You can choose either percent or pixel widths.</td>
</tr>
<tr>
<td>Cell Padding</td>
<td>Controls the CellPad value for the table that holds the imported data.</td>
</tr>
<tr>
<td>Cell Spacing</td>
<td>Controls the CellSpace value for the table that holds the imported data.</td>
</tr>
<tr>
<td>Format Top Row</td>
<td>You can apply a number of different formatting options to the first row of data in your table.</td>
</tr>
<tr>
<td>Border</td>
<td>Controls the table’s border width.</td>
</tr>
</tbody>
</table>
3. Leave the rest of the settings at their default settings. Click **OK**. This will import the data into Dreamweaver MX inside a custom table.

This is what your page should look like at this point.

4. **Save** and leave this file open for the next exercise.
Nested Tables and Borders

As you learned earlier, it is possible to modify the size and appearance of table borders through changing the width and border in the Property Inspector. In this exercise, we show you how to produce an outline appearance around the border of the table. This technique isn’t accomplished through the Property Inspector; it’s created instead through nesting tables. If you like this technique, don’t forget to share this trick with someone you know. ;-) 

The table on the left uses standard table properties to create its appearance. The table on the right uses nested tables to create the appearance of a stroked outline around the border of the cells and outer table. This technique offers an attractive alternative to the boring old tables we see everywhere.

1. The file from the previous exercise should be open; if it’s not, go ahead and open the import.html file located inside the chap_07 folder.
2. Click to the right of the table to place your blinking cursor outside the table. Press Return/Enter to move your cursor down.

3. Click the Insert Table object in the Common tab in the Insert panel. This will open the Insert Table dialog box.

4. Create a table with 1 Row, 1 Column, 90% Width, and 0 Border. Your dialog box should look just like the one shown above. Click OK.
This is what your page should look like after the new table has been added. Don't worry, you are going to make it look much better than this!

5. Click inside the new table you just created. In the **Tag Selector**, click on `<table>` to quickly select the entire table.
6. In the **Property Inspector**, click the **Bg Color** option and select **black**. The color you select for the background will also be the color of your table borders.

7. Select the top table using the **Tag Selector**, just like you did in Step 5. In the **Property Inspector**, change the **Width** to **100%**, **CellPad** to **5**, and the **Border** option to **0**.
8. Move your cursor to the upper-left corner of the table until it turns into a small hand (Mac) or a four-headed arrow (Windows). Then, click and drag the upper table into the lower table. Your nested tables should look like the one shown above. Everything will turn black! Don’t worry, you’ll fix this soon.

9. Click inside the upper-left cell and drag to select all of the cells in the table.
10. In the Property Inspector, set the Bg Color option to White. This will change the background of each individual cell to white so you can see your text and the black table borders.

11. Press F12 to preview this page in your default browser. Here, you can clearly see how the inner table is used to color the border of the outer table. Pretty neat, huh?

12. Click anywhere inside the table so the Tag Selector looks like what you see here. In the Tag Selector, click the second instance of the `<table>` tag to select the inner table.
13. Try setting the **Cell Padding** and **Cell Spacing** of the inner table to 0. Then preview the page again in a browser. Another cool effect. Go ahead and experiment with other settings. You can’t break anything, so just have some fun.

This is what the page looks like with the **Cell Padding** and **Cell Spacing** set to 0. As you can see, by adjusting these two options, you can dramatically change the appearance of the table border.

14. Return to Dreamweaver MX. **Save** and **close** this file.
Rounded-Corner Tables

Tables, like most things on the Web are square. Images are square, frames are square, the browser window is square; it seems like almost everything on the Web is square. It's no wonder Web designers are always looking for ways to make things look less square. This handy little trick is one way to make your tables look less boxy. This is another one of those custom tricks you might want to share with your friends, or perhaps not share with your competitors!

1. Open the rounded_done.html file located inside the chap_07 folder. This is the completed file for this exercise, so you can see the effect you're aiming for in this exercise.
This is what the finished table looks like in the browser. Notice that as the browser window changes size, so does the table.

2. Press F12 to preview this page in a browser. Go ahead and resize the window of your browser; notice how the table size adjusts with the size of the window. This occurs because the table is set to a percentage width, in this case 75%.

3. Return to Dreamweaver MX.

Now you know where this exercise is going, it's time to get started. The following steps walk you through the whole process of creating this same table.

4. Create a new document and save it inside the chap_07 folder as round.html.

5. Create a new table that has 3 Rows, 3 Columns, Width 75 Percent, Borders 0, and Cell Padding and Cell Spacing of 0. Your dialog box should look just like the one shown above.
6. Click inside the upper-left cell. In the Property Inspector, set the Horz option to Left and the Vert option to Top. This will ensure that the images you insert into this cell are aligned in the upper-left corner of the cell.

7. Click the Insert Image object on the Common tab in the Insert panel and browse to the chap_07/images folder. Click to select the topleft.gif file and click Open. This will insert that image into the table cell.

8. Click inside the upper-right cell. In the Property Inspector, set the Horz option to Right and the Vert option to Top. This will ensure that the images you insert into this cell are aligned in the upper-right corner of the cell.
9. Click the Insert Image object and browse to the chap_07/images folder. Click to select the topright.gif file and click Open. This will insert that image into the table cell.

10. Click inside the lower-left cell. In the Property Inspector, set the Horz option to Left and the Vert option to Bottom. This will ensure that the images you insert into this cell are aligned in the lower-left corner of the cell.

11. Click the Insert Image object and browse to the chap_07 folder. Click to select the bottomleft.gif file and click Open. This will insert that image into the table cell.

12. Click inside the lower-right cell. In the Property Inspector, set the Horz option to Right and the Vert option to Bottom. This will ensure that the images you insert into this cell are aligned in the lower-right corner of the cell.
13. Click the **Insert Image** object and browse to the **chap_07/images** folder. Click to select the **bottomright.gif** file and click **Open**. This will insert that image into the table cell.

14. Click in the upper-middle cell. In the **Property Inspector**, type **100%** for the **Width** option. This will cause the center cell to expand with the width of the table.
15. Use the Bg color option to sample the color of one of the green images. This will change the background color of that cell so that it matches the corner images.

16. Use this same process to color the other cells. When you are finished, your table should look like this.
17. Press F12 to preview this page in a browser. Resize the browser window. Notice how the table changes size and the corners all stay in their correct positions.

18. Return to Dreamweaver MX. If you want to experiment, try adding some text to the middle cell. There are lots of variations on this technique. Save and close this file.

Phew, you made it again, another chapter under your belt! You deserve a break; this was a long chapter!