In traditional layout programs, such as Adobe PageMaker, inDesign, and QuarkXPress, most people take it for granted that they can move blocks of text and images around almost anywhere on the screen. Unfortunately, standard HTML doesn’t contain any tags that allow you to easily position elements. You’ve learned how you can use tables to position your elements both horizontally and vertically on your Web pages, but creating a basic table still doesn’t give you the precision that you get in traditional print layout programs. This has caused considerable frustration among Web page designers.

Fortunately, Dreamweaver MX has built-in functions that help you work in a visual mode to create precise alignment for your text and images. You’ll learn how to position your elements both horizontally and vertically on your Web pages, but creating a basic table still doesn’t give you the precision that you get in traditional print layout programs. This has caused considerable frustration among Web page designers.

Fortunately, Dreamweaver MX has built-in functions that help you work in a visual mode to create precise alignment for your text and images. You’ll learn how to align your images using tracing images and layers, which you can then convert into tables that can be viewed on nearly any browser. Dreamweaver MX has an alternative layout feature called layout cells—which gives you the freedom of absolute positioning while still conforming to strict HTML table guidelines!

In this chapter, you’ll learn several techniques that allow you to position elements anywhere on your Web page, such as tracing images and layers, converting layers to tables, and working with layout tables and layout cells. After completing these exercises, you can decide for yourself which method you prefer when building your own pages.
What Are Tracing Images, Layers, and Tables?

The following chart outlines the concepts behind tracing images, layers, and tables, which you will learn about in the following exercises:

<table>
<thead>
<tr>
<th>Item</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tracing image</td>
<td>An image (GIF, JPEG, or PNG) that can be loaded into the background of your Web page to serve as a reference for layout. Consider this the blueprint you follow to build your pages.</td>
</tr>
<tr>
<td>Layer</td>
<td>This is where you put your text and images so you can move them around freely. The downside to using layers is that they work only on 4.0 browsers and above.</td>
</tr>
<tr>
<td>Table</td>
<td>Tables can hold images and text in place, but they are not intuitive or flexible when it comes to positioning them on the screen. However, Dreamweaver MX offers some helpful features that give you more flexibility, including the ability to convert layers to tables, and innovative table drawing tools.</td>
</tr>
</tbody>
</table>
Applying a Tracing Image

Imagine that you have mocked up a wonderful layout for a Web page in Photoshop, Fireworks, Illustrator, or any drawing or painting program of your choice. Wouldn’t it be great if you could take that mockup and put it up on the Web? If you save your mockup as a GIF, JPEG, or PNG, you can work with it easily as a tracing image. Dreamweaver MX’s tracing image feature allows you to place any GIF, JPEG, or PNG into a tracing layer on your page, which can then be used as a reference for you to use to align your HTML elements to match up to it perfectly.

In this exercise, you will learn how to apply a tracing image to your Web page, as well as how to change its transparency and position on the page. You’ll work with a tracing image that is supplied from the H•O•T CD-ROM. If you were to create your own tracing image, you would create a composite of your Web page in a graphics application of your choice, such as Photoshop, Fireworks, Illustrator, or whatever, and save it as a GIF, JPEG, or PNG. You would then specify your design as a tracing image in Dreamweaver MX, so that you could use it as your guide to re-create your page design.

A tracing image is visible only in Dreamweaver MX. Visitors to your site cannot see it. Keep in mind that when you are viewing the tracing image in Dreamweaver MX while building your page, you cannot see the background image or background color that you are setting, unless you decrease the tracing image’s transparency setting. You’ll learn to do this in the following exercise.

1. Copy chap_08 from the H•O•T CD-ROM to your hard drive. Define the site for Chapter 8 using the chap_08 folder as the local root folder. If you need a refresher on this process, visit Exercise 1 in Chapter 3, “Site Control.”

2. Open index.html. This page is empty except that it already contains the Title “Chapter 8” and the colors for Text, Links, Visited Links, and Active Links have been preset for you. Choose Modify > Page Properties to see these settings. The shortcut keys for this are Cmd+J (Mac) and Ctrl+J (Windows).
3. Click **Browse** next to the **Tracing Image** field.

4. Browse to **tracingimage.jpg** inside the **images** folder and click **OK**.
5. For this exercise, make sure the **Image Transparency** slider is at **100%**. This will enable your tracing image to be visible in the document window of Dreamweaver MX.

6. Click **OK** to close the **Page Properties** dialog box.

This is what your page should look like with the tracing image applied. It was inserted at 100% opacity in the Page Properties dialog box, which makes it opaque.
NOTE | Browser Offset

The white space you see above and to the left of the tracing image is the result of an offset that Dreamweaver MX created. By default this offset is X:8 Y:11. This means that the image is offset 8 pixels from the top and 11 pixels from the left of the document. You can modify this offset by choosing View > Tracing Image > Adjust Position.

Why does Dreamweaver MX introduce such an offset? The program is emulating what would happen in a Web browser. For some kooky reason, browsers do not display foreground images flush top and left, but that's exactly how they display background images—flush top and left. This means that any image in the foreground (meaning it is not a background image) will always be displayed in the browser with this offset. Dreamweaver MX allows you to get rid of the offset; however, the offset is intentionally there to show you how the foreground artwork will align in a Web browser.

Dreamweaver MX offsets tracing images from the top-left corner to emulate an offset that exists in 3.0 or older Web browsers. You can get rid of this offset if you like. We usually leave the offset alone, because it represents what will happen in a browser, anyway. If you have not accounted for this offset in the design of your tracing image, we suggest you don’t change this setting.

You can use the Adjust Tracing Image Position dialog box to set the offset anywhere you want. In some cases, you may want to set the image to X:0 and Y:0. For this example, bring up this dialog box, choose View > Tracing Image > Adjust Position and enter X:40 and Y:40. This will move the tracing image towards the center of the document.
7. Press **F12** to preview this page in a Web browser (if you have not defined a browser yet, this is explained in Chapter 2, “Interface”). When you do this, notice that the page appears as a blank screen. This is supposed to happen! The tracing image appears only in Dreamweaver MX, and it won’t be visible to your end user.

8. Return to Dreamweaver MX and choose **Modify > Page Properties** to access the tracing image settings again.

![Page Properties](image)

9. Drag the **Image Transparency** slider down to **50%** and click **OK**.

![Chapter 8 Image](image)

With the opacity reduced, it’s much easier to use the tracing image as a guide because it doesn’t compete with foreground images and text that are by default set to full opacity.

10. Choose **File > Save** and leave this file open for the next exercise, in which you’ll add images to match this layout.
Tracing Images, Background Colors, and Images

Once you apply a tracing image to your page, it will hide the background color and background images while you are editing the document inside Dreamweaver MX. However, if you view the page that contains the tracing image from a browser, the background color and/or background image will be visible, and the tracing image will not. In other words, tracing images are only visible to you while you're working in Dreamweaver MX. This is a good thing, because you don't want people seeing your blueprint—you want them to see the final results.

Remember, the tracing image is an internal function of Dreamweaver MX to help you follow a preconceived layout. When you preview the Dreamweaver MX file above in a browser, it appears empty because there is no placed artwork yet.
2. Adding Layers

In previous chapters, you have been putting artwork and text directly on your page or inside tables. With that method, you can right-, left-, or center-align elements, and that's the end of the story. This frustrates most people because it would be much easier if you could stick that artwork or text anywhere you wanted on the page and have it stay there. Layers are your friends, because they can be positioned anywhere without restriction. Rather than simply placing artwork and text on a page, as you have been doing so far, you can put your content into layers and move it anywhere you want.

In this exercise, you will learn how to create layers on your page and insert images and text inside them. Then—presto, you'll be able to move everything around. Ahh, the beauty of layers!

1. With index.html still open from the last exercise, choose Insert > Layer. If you prefer, you can select the Layer object from the Insert panel and hand draw your layer by clicking and dragging a box onto the document window.
When a layer is selected, the layer handle and eight resizing handles will appear around the border of the layer.

Notice the yellow thingie in the upper-left corner? It’s called an invisible element in Dreamweaver MX. If you deselect the layer by clicking outside its boundaries, you’ll see that the invisible element is deselected as well. For more on invisible elements, see the “Invisible Element Markers” sidebar later in this chapter.

2. Next, you will move the layer to a new position on the page. Because the layer handle is hiding at the top of the document, you need to select the layer using the invisible element marker. Make sure that visual aids are enabled so that you can see them. If necessary, select View > Visual Aids > Invisible Elements.

Click on the small yellow icon that appears at the top of your page. This will cause eight resizing handles to appear around the layer.
3. Move your cursor over the edge of the layer and click and drag to move the layer so that its upper-left corner aligns with the photo of the slanting style bonsai that is visible in the tracing image. Using the bottom-right resizing handle, resize the layer so that it fits around the edge of that tree’s image.

4. Click inside the layer. You should see a blinking I-beam cursor inside the layer.

5. Open the **Assets** panel if it is not already open. Click the **Images** radio button to select **Image Assets**. Select the **slanting_style.jpg** and drag it into the selected layer.

An image is now inside the layer. Notice how this image is darker, whereas the tracing image is screened back? That’s because you set the tracing image’s opacity to 50% in the last exercise. This makes it easy to distinguish between the layout and the final artwork, doesn’t it?
WARNING | Invisible Element Markers

As mentioned earlier, when you create a layer in Dreamweaver MX, a small yellow icon appears at the top of your page. This is referred to as an invisible element marker. Each time you create a layer, a yellow marker will be inserted. By selecting these markers, you can easily select the associated layers. When the yellow icon is selected, it becomes a blue icon, by the way!

You will see these markers in the index.html document after you have completed Exercise 2. If you find that these markers get in your way, choose View > Visual Aids > Invisible Elements to hide/show them all. You can turn off invisible elements permanently if you want, by choosing Edit > Preferences > Invisible Elements.

This is what an invisible element marker looks like in Dreamweaver MX.

You can turn invisible elements on or off permanently in Dreamweaver MX’s Preferences, available under the Edit menu. You can also choose View > Visual Aids > Invisible Elements to turn the Invisible Elements view on and off as you need to.
6. In the **Insert** panel, click the **Draw Layer** object. If you have a different Insert panel visible, click on the small tab at the top of the panel and select **Common** to switch back to it.

7. With the **Draw Layer** tool selected, draw a layer around the image of the **Informal Upright bonsai**. You’ve just inserted a layer by using the Insert panel instead of the Insert menu. Either way works fine, and you have now been exposed to both.

8. Make sure your blinking cursor is inside the layer and drag the **informal_upright.jpg** into this layer.

9. Add another layer around the remaining tree. You can use either the **Insert** panel or the **Insert** menu to accomplish this.

10. Drag the **formal_upright.jpg** image from the **Assets** panel into this layer.
11. So far you have inserted images into layers. Inserting text is just as simple. Add another layer around the Choosing a Bonsai Style text panel at the left side of the page.

12. Click inside the layer and type the text as you read it on the screen, or you can open the style.txt file with a text editor, select all the text, copy it, and paste it into the layer.

Normally you would now format this text. However, for the purpose of this exercise, don’t worry too much about matching the type of the original layout. If you need a refresher on type, revisit Chapter 6, “Typography.”

13. At this point, you will probably want to adjust the position of the layers to more closely match the tracing image. To do this, click on the layer’s selection handle to select the whole layer and its content. Then you can either drag the layer to a new position, or you can use the arrow keys on your keyboard to nudge the layer around the document one pixel at a time. **Tip:** Holding the Shift key while pressing the arrow keys will move the selection in 10-pixel increments.
This is what your page looks like now. Most likely, your text won't perfectly match the tracing image. That's all right—the tracing image is there only as a guide.

14. Press F12 to preview this page in a browser. Notice once again that the tracing image disappears. Only this time, you've re-created the layout using layers. When you are finished marveling at this accomplishment, return to Dreamweaver MX and save the file. Leave this document open for the next exercise.

MOVIE | layers.mov

To learn more about using layers, check out layers.mov located in the movies folder on the Dreamweaver MX H•O•T CD-ROM.
3. **Converting Layers to Tables**

You’ve just positioned artwork precisely to match a specific layout. As you may recall from the introduction to this section, layers display only on version 4.0+ browsers. People using earlier browsers will see the content of the layers all jumbled up along the left side of your page, which, of course, is not cool at all! We’re guessing that you want the luxury of freely positioning artwork with layers, but still want people with older browsers to view your site. This exercise will show you how to convert layers to standard HTML tables, so anybody can see your perfect layout, no matter what browser they’re using.

1. With *index.html* still open from the last exercise, choose **Modify > Convert > Layers to Table**. The **Convert Layers to Table** dialog box will open.

2. Click **Table Layout: Most Accurate**. Check the **Prevent Layer Overlaps** checkbox. This setting is required because layers can overlap, but tables cannot. Leave the **Use Transparent GIFs** option selected. This will insert a transparent GIF into your layout as needed to ensure that your table doesn’t collapse in some browsers. Click **OK**.
When you convert your layers to tables, by default Dreamweaver MX will set the table borders to 0, as shown above in the Property Inspector. Why? You do not want to advertise that you are using tables. The 0 gives you an invisible border, creating the illusion of floating background images and text on your Web page.

You can access the table properties by clicking anywhere in the table, and then selecting the `<table>` tag at the bottom of the document. The Property Inspector will reveal the different table settings.
3. Preview the results in a browser by clicking **F12**. Notice that in the browser you can't tell whether layers or tables were used. Converting layers to tables affects the compatibility of the HTML document, not the appearance. Return to Dreamweaver MX.

4. For a final touch, choose **Modify > Page Properties** and change the background color to **#FFFFCC** (or you can sample the yellow color that surrounds the tree images).
This is more or less what your page looks like now. The outcome of the new table will vary depending on how the edges of the layer boxes are aligned.

5. Preview the results in a browser by clicking **F12**. Now the images appear seamless against the background of the page. Return to **Dreamweaver MX**. Save the file and leave it open for the next exercise.
Convert Layers to Table Options

The Convert Layers to Table dialog box has several options to help you control how your layers are converted. The following chart explains how these features work:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Most Accurate</strong></td>
<td>This default option creates a table cell for each layer and all the cells necessary to maintain the layer structure. More information about tables and cells can be found in Chapter 7, “Tables.”</td>
</tr>
<tr>
<td><strong>Smallest: Collapse Empty Cells</strong></td>
<td>This option sets the edges of the layers to align if they are within a certain pixel range of each other. This typically results in fewer columns and rows. This can be a good thing, because fewer columns and rows equate to faster downloading; or it can be bad thing, because it can potentially disrupt your layout’s appearance. We recommend experimenting to see which suits your needs best.</td>
</tr>
<tr>
<td><strong>Use Transparent GIFS</strong></td>
<td>This option inserts transparent GIFs in each of the empty cells. This helps maintain the table structure across browsers. Tables can collapse in some browsers if they don’t contain content, and transparent GIFs can fill in as content, though they are invisible.</td>
</tr>
<tr>
<td><strong>Center on Page</strong></td>
<td>This option centers the table on the page.</td>
</tr>
<tr>
<td><strong>Prevent Layer Overlaps</strong></td>
<td>Table cells cannot overlap. This option prevents you from overlapping your layers by warning you about which layers, if any, overlap.</td>
</tr>
<tr>
<td><strong>Show Layers Panel</strong></td>
<td>This opens the Layer panel, which allows you to rename or reorder your layers.</td>
</tr>
<tr>
<td><strong>Show Grid</strong></td>
<td>If it’s not already visible, this will turn on the grid for the page.</td>
</tr>
<tr>
<td><strong>Snap To Grid</strong></td>
<td>This snaps the layer to the nearest snapping point on the grid. This can be useful for aligning objects.</td>
</tr>
</tbody>
</table>
In this exercise, you will convert the table version of your page back to layers, modify the layout, and then convert it back to tables for browser compatibility. You will turn the tracing image off and be encouraged to modify the page’s layout however you want. When you are finished, you should definitely appreciate how powerful these features are in helping you create and modify the layout of your pages.

1. With index.html still open from the last exercise, choose Modify > Convert > Tables to Layers. The Convert Tables to Layers dialog box will open.
2. Remove the checkmark in the **Snap To Grid** checkbox. If checked, this option will force your layers to snap to a grid, sometimes causing unwanted shifting of page elements. For this reason, we prefer to not use this option. Make sure that your settings are like those shown above and click **OK**.

Your table is converted into layers, and the grid is turned on to help with the layout of your page. If you want to change the layout, you’ll find that it’s much easier to do so with layers than with tables! If the grid bothers you, turn it off by choosing View > Grid > Show Grid. We find it helpful, so we leave it on.
3. Click the layer that contains the Slanting Style image. Use the Layer Selection Handle to drag this layer up so that the top of it aligns with the top of the Formal Upright image.

**Note:** When you click and drag on a layer, it becomes highlighted in the Layers panel.

4. Select the layer containing the Informal Upright image. Use the layer selection handle to drag this layer to the right so that it is centered below the other two images.

5. Select the layer with the text in it. Align it with the top of the tree in the Formal Upright image. We decided it was time to format the text, so for the headline **Choosing a Bonsai Style**, we used **Georgia, Bold**, size 2. For the rest of the copy, we used **Verdana**, size 2.
Here is the new layout in Dreamweaver.

6. Choose **Modify > Convert > Layers to Table. Click OK.**

7. Press **F12** to preview the file in a browser.

8. **Save** and **close** the file.
You can start to see how easy it is to change the layout of your pages by converting back and forth between layers and tables. On the left is the original page and on the right is the new page, with the artwork rearranged.

**What is the Layout View?**

Dreamweaver MX contains a great way to create the layout for your Web pages. The **Layout** view feature allows you to create layout cells and tables by drawing them exactly where you need them, at exactly the size that you want. This technique was introduced in Dreamweaver 4 as a more visual way to design your layouts while creating clean and optimized table code behind the scenes. Although converting from layers to tables is convenient and easy, it does not write nested tables (tables that are within other tables). Instead, it must produce table code that is not as “clean” or as optimized as possible. Layout cells and tables, on the other hand, are written in a very clean manner and can include nested tables.

Layout tables and cells are indicated by different symbols to describe what kind of table cell (fixed-pixel or percentage-based) is being used.
Layers to Tables versus Layout View

During the course of this chapter, you were shown how to create Web-page layouts using two different methods; first, with layers and then converting layers to tables. Next, you’ll learn how to create layouts with the Layout view using layout cells and layout tables. At this point, you might be scratching your head and wondering which one you should be using for your page layouts. Although there are some pros and cons to both, much of it boils down to a matter of preference. We always suggest that you find a workflow that makes you comfortable and stick with it. Just because there are many ways to accomplish the same thing doesn’t mean you have to use them all. The following table outlines some of the pros and cons of each workflow:

<table>
<thead>
<tr>
<th>Item</th>
<th>Pros</th>
<th>Cons</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Layers to Tables</strong></td>
<td>Easy to use and do not require knowledge of table behaviors and restrictions.</td>
<td>The table code generated in this process is often overly complex.</td>
</tr>
<tr>
<td></td>
<td>Easy to save a layer-based and table-based version of your page.</td>
<td>More difficult to create layouts with percentage based-designs.</td>
</tr>
<tr>
<td><strong>Layout view</strong></td>
<td>Easy to create layouts with percentage-based designs.</td>
<td>Requires knowledge of table behavior and restrictions.</td>
</tr>
<tr>
<td></td>
<td>Table code is optimized and very clean.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Will automatically create and insert <strong>spacer.gif</strong> into your layout.</td>
<td></td>
</tr>
</tbody>
</table>
5. **Layout Tables and Layout Cells**

This exercise shows you how to use layout cells and layout tables to create a navigation bar that stretches with the width of the browser window. It combines the use of fixed table cells and percentage-based table cells using the Layout Cell editor.

1. Open the `navbar_done.html` file located inside the `chap_08` folder. This is the finished version of the file you will create in this exercise.

2. Click the Layout tab on the Insert panel and then click the Layout View button. This will switch the view of your document to the Layout view.
Layout View vs. Standard View

You learned earlier that Dreamweaver MX has three different views for your document window: the Design view (default), Design and Code view, and Code view. In addition to this, there are two ways to view the Design view: the Standard view (default) and the Layout view. The Standard view is where you will do most of your work, such as inserting objects, text, and links. The Layout view is an alternative, flexible mode for constructing the layout of your page. However, while in the Layout view, you cannot use the Insert Table object or create layers. Despite these few limitations, the Layout view lets you design your pages in a visual manner while creating clean and optimized table code behind the scenes.
3. The **Getting Started in Layout View** dialog box will appear. This is just a simple introduction and explanation of the Layout view, layout tables, and layout cells. Once you've read this, you probably won't want to read it again, so we suggest you select the **Don't show me this message again** checkbox.

This is what the page looks like in Layout view. Notice that the appearance of the table has changed quite a bit. By the end of this exercise, you will know what this change in appearance means and how to work in this mode.
4. Press **F12** to preview this page in a browser. Resize your browser window. Notice that the text content stretches with the size of the browser window. This design is effective because it can accommodate almost any resolution. Woo-hoo!

5. Return to Dreamweaver MX. Close `navbar_done.html`.

The following steps will walk you through the process of creating this page using layout tables and cells in the Layout view.

6. Create a new document and save it inside the `chap_08` folder as `navbar.html`.

7. At the bottom of the **Insert** panel, click the **Layout View** button.

8. Click the **Draw Layout Cell** icon on the **Insert** panel. This will let you draw a table cell in your document window.
9. Starting from the upper-left corner of your document, click and drag to create a cell that is approximately 242 x 60 pixels. Don’t stress yourself out trying to get it exact. You will learn how to adjust the size in a few steps—just get as close as you can.

Table cells cannot exist without a table—that’s a fact of Web design. So, when you create a table cell, Dreamweaver MX will automatically create a table to hold the cell, as dictated by HTML guidelines. That’s exactly what happened here and that’s what you see on your screen. A green Layout Table tab will appear in the upper-left corner, indicating that a table has been created. The table cell will appear with a light blue border around it.

10. Move your cursor over the edge of the layout cell. The border of the layout cell will turn red indicating that you will select that cell if you click. Well, guess what? Click to select that layout cell. ;-)

The Property Inspector will change to display the editable options for the layout cell. Notice that you can numerically adjust the width and height of the cell here.
11. In the Property Inspector, change the Width to 242 and press Return/Enter. Then change the Height to 60 and press Return/Enter.

12. Click the Draw Layout Cell icon in the Insert panel again.

13. Click and drag another layout cell to the right of the first cell. This cell should be 30 x 60 pixels. If you don’t get it exactly right, use the Property Inspector to adjust the Width and Height.

Notice how the cell snaps to the guidelines? This will help ensure that your tables aren’t overly complex.
TIP | Drawing Multiple Layout Cells

As you work with the layout cells feature, you will find yourself creating several cells at once. However, each time you draw a cell, you need to reselect the Draw Layout Cell object before you can create another one. This can get annoying and slow down your workflow quite a bit. Don’t worry, there is a solution! If you hold down the **Cmd** (Mac) or **Ctrl** (Windows) key while you draw a layout cell, you can draw as many cells as you want without having to reselect the object each time. Nice.

14. Click the **Draw Layout Cell** icon in the Insert panel again and draw a cell to the right that extends to the end of the table. It should have a height of 30 pixels.

15. Click the **Draw Layout Cell** icon in the Insert panel and draw another cell right below that is the same size.
16. Click the green **Layout Table** tab in the upper-left corner to select the **Layout Table**. Click and drag the middle resize handle at the bottom of the table to bring it up to the bottom of the cells. You don't want the table to be any bigger than necessary.

This is what your layout should look like at this point.

17. Click the border of the large cell on the left to select it. In the **Property Inspector**, change the background color of this cell to **#FFFFCC**, which is a nice shade of yellow.
18. Click the border of the middle cell to select it. In the **Property Inspector**, change the background color of this cell to **#FFFFCC**.

19. Using this same process, change the background of the two long horizontal cells to **#999966**.

20. Click inside the large cell on the left and insert the **logo.gif** image into that cell.
21. Click inside the middle cell and insert the tip.gif image into that cell.

22. Click to select the border of the upper-right horizontal cell. You are going to insert some text into this cell, so you will first modify its alignment properties.

23. In the Property Inspector, change the Horz alignment to Right and the Vert alignment to Middle. This will place any text in this cell in the middle and align it to the right side of the cell.

24. Click inside the upper-right cell and create a text navigation like the one shown above. Make sure you change the text color to white or some other light color. We changed the font to Verdana at a size of 2. If you are using a Mac, you may want to use size 1 for the text.
25. Press **F12** to preview your page in a browser. Things look good, but the table doesn’t stretch with the browser window. The following steps will show you how to make the table stretch with the browser window.

26. Return to Dreamweaver MX.

27. Click the green arrow above the middle of the upper-right cell. Select **Make Column Autostretch**. This option will set the right column to 100% so that it stretches with the browser window. Simple huh?

In order to prevent the table from collapsing in some browsers, Dreamweaver MX needs to insert an invisible GIF inside the cells with no content. Don’t worry if you don’t have an invisible GIF file, Dreamweaver MX will even create one for you. The following dialog box displays the different options available to you.
28. Make sure the **Create a spacer image file** radio button is selected and click **OK**. This will cause Dreamweaver MX to create a **spacer.gif** file—a transparent GIF image—and insert it into the cells with no content.

29. Browse to the **images** folder inside the **chap_08** folder and save the **spacer.gif** file there.
Notice that the tops of all the cells have changed. The following chart explains what each of these different visual cues mean.

### Anatomy of Layout Cells

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Layout Cell with Numeric Value" /></td>
<td>A layout cell with a numeric value displayed at the top means that the cell has a specific width value set in pixels. This value can be changed with the resize handles or in the Property Inspector.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Layout Cell with Thick Double Line" /></td>
<td>A layout cell with a numeric value and a thick double line is an indication that the cell is set to a specific pixel value, and it also contains a <code>spacer.gif</code>. This occurs when another column has been set to Autostretch.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Layout Cell with Squiggle" /></td>
<td>A layout cell with a little squiggle at the top is an indication that this column has been set to Autostretch, which means that it will stretch to fill the remaining horizontal space in the browser window. This setting can be changed to a fixed-pixel value in the Property Inspector.</td>
</tr>
</tbody>
</table>
30. Press **F12** again to preview this page in a browser. Voila, your table will now stretch to the width of the browser window.

31. Return to Dreamweaver MX and **save** and **close** this file.

**MOVIE | layoutview.mov**

To see this exercise in action, check out **layoutview.mov** located in the movies folder on the Dreamweaver MX **H•O•T CD-ROM**.

You finished yet another chapter... congratulations, you might want to take a short break before moving onto Chapter 9, “Frames.”