So far in this book, you’ve learned to insert text, tables, and images into individual HTML pages. The concept of **frames** is a little more challenging because, in effect, a frame is an HTML page inside another HTML page. Why would anyone want to put an HTML page inside another HTML page? So that one part of a page can update independently from another.

Let’s say that you’ve created an image that belonged at the bottom of an HTML page. If your site contained 100 pages, and you wanted to put that same image at the bottom of all of them, you would need to insert that image 100 times into each of those 100 individual pages.

Frames allow you to reuse a single HTML page by nesting it inside another HTML document (otherwise known as a **frameset**). This would make it possible to create that image at the bottom of an HTML page only once, but allow 100 other pages to load up above it. If it sounds complex, it is. Frames have a high learning curve, but fortunately this chapter is here to walk you through every step of the way.
What Are Frames?

Lynda's husband Bruce came up with this wonderful metaphor for teaching frames. Imagine a TV dinner. You've got your peas and carrots, an entrée and, if you are really lucky, a dessert. Don't forget, though, about the tray that holds all these food items together! A frameset, if you will, is the TV dinner tray that holds together multiple HTML documents.

If you were to build a frameset that contained two frames, a left frame for your Web navigation element and a right frame for your content, visitors to your site would see only two frames. What's hidden is that your visitor would actually be working with three documents: a frameset (think TV dinner tray) and two frames (the content HTML page and the navigation HTML page). Every time you come to a page that contains frames, it always includes a frameset that holds the frames in place. If this sounds confusing at all, welcome to frames! Conceptually, they can be a bit of a brain twister.

We promise that the exercises in this chapter will help you unravel these concepts. You'll learn that frames are controversial creatures, and that they are either loved or hated by most people. We do our best to fill you in on the pros and cons of using frames, as well as a variety of techniques for using them effectively and creatively. In the end, you will have the honor of deciding if they are right or wrong for your site. Hey, we just teach this stuff!
Frames: A Love-or-Hate Proposition

First, a word from our sponsors (the venerable authors of this book). Frames are controversial—most people either love or hate them. You may want to consider the pros and cons before you use them in your site. Here are two charts to help you if you’re weighing the decision to use or not use frames:

<table>
<thead>
<tr>
<th>Pro</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Good workflow</td>
<td>It’s easier to update a single page than hundreds, right? If you put a navigation element (all your links) into a single frame of a frameset, and then your site’s navigation changes, you have to update only that one page.</td>
</tr>
<tr>
<td>Fixed navigation</td>
<td>The entire page doesn’t have to reload each time a link is clicked, only sections of the page. This means that you can anchor a navigation page so it doesn’t have to be reloaded with each new page click and always stays consistent throughout your site.</td>
</tr>
<tr>
<td>Special effects</td>
<td>Frames let you do cool special effects, such as putting a single background into multiple frames for aesthetic purposes. You’ll learn this technique in this very chapter!</td>
</tr>
</tbody>
</table>
## Hate Frames

<table>
<thead>
<tr>
<th>Con</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confusing</td>
<td>If not well implemented, frames can create confusing navigation for your audience. However, this chapter teaches you how to implement frames well, of course!</td>
</tr>
<tr>
<td>Printing hassles</td>
<td>It is not possible to print an entire frameset. That would be like printing three or more HTML pages at once. Your end user can print an individual frame, but frames are often transparent to the end user so this can prove challenging. Our suggestion? If you think people are going to print a page from your site, don’t put it in a frameset.</td>
</tr>
<tr>
<td>Bookmark hassles</td>
<td>The only part of a framed page that can be bookmarked easily is the frameset. Let’s say you have 20 pages that load into a single frameset. If one of your end users wanted to bookmark page 11, he/she would not be able to do so, because only the first page that loads into the frameset could be bookmarked. We have no remedy for this problem, except to say that you should make it very clear how to get to the other 19 pages within that frameset, by adding a simple navigation path, a horizontal listing of links of all previously visited pages, on the first page.</td>
</tr>
<tr>
<td>Hidden security issues</td>
<td>At the lynda.com Web site, we once made the mistake of placing a secure order form into an insecure frameset. Some of our customers complained because they couldn’t see the lock symbol at the bottom left of their browsers that ensures a page is secure. Although the order form page was in fact secure, we eventually took it out of the frameset so our customers would see the lock symbol and feel more confident buying from us.</td>
</tr>
<tr>
<td>Too boxy</td>
<td>Frames divide an already small amount of screen real estate into smaller regions, which causes a boxy effect. You’ll learn how to make framesets without unsightly scrollbars and borders. That will help eliminate the ugly boxy effect.</td>
</tr>
<tr>
<td>Accessibility</td>
<td>Frames can be very problematic from an accessibility perspective. They can be difficult, if not impossible, to view on some devices, such as screen readers. Navigating from frame to frame can be difficult for some devices as well.</td>
</tr>
</tbody>
</table>
Saving Your First Frameset

This chapter is going to build your frame-making skills gradually. This first exercise shows you how to save a set of frames properly. Sounds simple? Unfortunately, saving frames is one of the more difficult aspects of learning how to build framesets. By taking you slowly through the process, our hope is that you’ll get through these hurdles without a problem.

1. Copy chap_09 from the H•O•T CD-ROM to your hard drive. Define your site for Chapter 9 using the chap_09 folder as the local root folder. If you need a refresher on this process, visit Exercise 1 in Chapter 3, “Site Control.”

2. Start this exercise with a blank untitled document. Don’t save this page just yet. You may be surprised by this advice, given our past warnings, but saving now will cause Dreamweaver MX to believe that this is a single HTML page (which it is not!). You are going to divide this into a frameset and frames before you save.

3. Choose Modify > Frameset > Split Frame Left. This puts a vertical frame divider through your page. What’s more, it switches you from looking at one page to looking at three: the frameset, the left frame, and the right frame.
4. Choose **File > Save Frameset As** and save the file as `frameset.html` inside the `chap_09` folder. The frameset document will be the container for the other HTML files.

**Note:** If you wanted this frameset to be the first page in your site (often referred to as the home page), you would save the frameset as `index.html`.

---

**MOVIE | saving_frames.mov**

To learn more about saving frames, check out `saving_frames.mov` located in the `movies` folder on the Dreamweaver MX H•O•T CD-ROM.
5. Click inside the left frame and select File > Save Frame As and save the file as left.html. Make sure you are saving this file in the same location as the frameset.html file.

6. Click inside the right frame and select File > Save Frame As and save the file as right.html. Make sure you are saving this file in the same location as the frameset.html file.

Even though you just saved these files, notice that it says Untitled Document at the top of each document window. What's up with that? As you learned in Chapter 4, “Basics,” you’ve saved and named the HTML document, but have not assigned the title yet. To set the title, be sure to follow the exact directions in the following steps, because you are juggling three HTML documents and you want to put the title in the outermost page (frameset.html).
7. Select Window > Others > Frames to open the Frames panel. This panel will give you a preview of your frameset structure and can be helpful for selecting different portions of your frameset.

8. Click on the outermost border around the edge of the Frames panel. It has a thick black edge when it is selected. This is a quick way to select the frameset. In the toolbar at the top of the document, enter in the Title field: My First Frameset, and press Enter. The default untitled document title should be instantly replaced by your new title. Note: Press Enter only after you deselect your new title; otherwise, it will be deleted!
9. Choose **File > Save All**. Once you define the initial frameset and frames, you can perform one simple **Save All Frames** operation to save the changes to all the files and be done. Leave this file open for Exercise 2.
Different Ways to Save Frames

This exercise taught you to save frames by choosing **File > Save Frame As**. There are a few different ways to save them besides this, but the way we already showed you is the best because you always know what file you are saving. All three ways are listed in the handy chart below.

<table>
<thead>
<tr>
<th>Option</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt; Save Frame</td>
<td>To save a document inside a frameset, click the cursor in the frame and use this method.</td>
</tr>
<tr>
<td>File &gt; Save Frame As</td>
<td></td>
</tr>
<tr>
<td>File &gt; Save Frameset</td>
<td>To save a frameset file only, you may choose to use either of these methods.</td>
</tr>
<tr>
<td>File &gt; Save Frameset As</td>
<td></td>
</tr>
<tr>
<td>File &gt; Save All Frames</td>
<td>To save all open files at once, use this method. However, we don’t recommend this method. There’s a known bug on the Mac that doesn’t give you a good visual cue about which file is being saved using this method. Using the <strong>File &gt; Save All Frames</strong> method after you’ve saved the first time using the other listed methods is fine. Just don’t start the process with a <strong>File &gt; Save All Frames</strong>, or you’ll potentially get confused by the process.</td>
</tr>
</tbody>
</table>
2. **Coloring Frames**

Coloring frames is challenging because you’re manipulating multiple HTML documents in one Dreamweaver MX window. This exercise teaches you how to color two frames independently. You’ll also learn how to turn off the borders between them, which can help eliminate that boxy appearance that many people don’t like about frames.

1. You should still have `frameset.html` open from the last exercise. In the document window, click on the **left frame** and make sure you see the text-insertion cursor blinking.

2. Choose **Modify > Page Properties** (Ctrl+J [Windows] or Cmd+J [Mac]). Make the **Background** a dark brown, the **Text** yellow-orange, the **Links** pale yellow, the **Visited Links** light brown, and the **Active Links** red. You can use the colors shown above or pick your own colors. Click **OK**.

The left frame should be brown at this point.

3. In order to change the color for the right side, click in the **right frame** and make sure you see the text-insertion cursor blinking. Choose **Modify > Page Properties** yet again.
4. Make the Background pale yellow, the Text black, the Links dark red, the Visited Links medium green, and the Active Links red. You can use the colors shown above or if you are feeling wild, go ahead and pick your own colors. ;-) Click OK. The right frame should turn pale yellow.

The left side of the document should be brown, and the right side yellow.
5. Click on the middle dividing frame border. Make sure the left frame in the Property Inspector is selected and enter the value **150** into the **Column** setting in the Property Inspector. Then press **Enter**.

6. We don’t know if you agree with us, but part of what we do not like about frames is their boxy appearance. To turn off the border on the frame divider, select **Borders: No**, and **Border Width: 0** in the Property Inspector. Now the dividing border should be gone. Choose **File > Save All** and leave this document open for the next exercise.
3. Links and Targets

You’ve gotten through the hardest part of making a frameset, but there’s still more distance to go to the finish. This exercise shows you how to insert a link into the left side page of the frameset. You’ve learned about making links, so much of this should be familiar. This exercise introduces a new concept, however—using a “target”—which allows you to specify which frame the link will trigger in your frameset.

1. Click inside the left frame and make sure you see the blinking text-insertion cursor. Type the words Bonsai Tools.

2. Select the words Bonsai Tools and click on the folder to the right of Link in the Property Inspector. Browse to the html folder inside the chap_09 folder and select tools.html. Click Open. Bonsai Tools should now appear as an underlined link.
3. You can't preview links in Dreamweaver MX, so press F12 to preview in your browser. You'll be prompted to save your files before you preview them in a browser, so click Save. Note: We suggest that you click the Don't warn me again checkbox so you don't see this message every time you test your frameset in a browser.

4. Once in the browser, go ahead and click the link Bonsai Tools. You might be surprised that the tools page appears in the left frame, the exact frame where the link was in your file! Just like in any other Web page, once you click on a link, it's replaced with whatever content to which it was linked. However, in this situation, the narrow left frame isn't where you want that linked page to appear. The left frame should remain stationary, and the linked pages should open on the right. The way to make this happen is by setting up a target for the link.

If you’d prefer (as we do) that the link load in the larger right side of the frameset, you must first name the two frames. Giving a name to an element in HTML is something you haven’t done yet, but you’ll see that it is necessary in certain instances throughout the exercises in this book. In this situation, you can’t target the right frame to receive the results of the link without first giving it a name.
Note: The directive to give the frame a name, because you've already saved all the documents with file names, frameset.html, left.html, and right.html, might confuse you. You also gave a title, My First Frameset, to the frameset.html document. Giving a "name" to an element in HTML, in order to set custom targets in links, is something totally different, however.

5. Return to Dreamweaver MX to fix the target problem. Make sure the Frames panel is open. If it's not, choose Window > Frames to bring it up. Notice that it reads (no name) on both the right and left sides? Click on the left side and it will become outlined with a dark line, as shown above.

6. The Property Inspector should now display the setting for the Frame Name field. Enter left. You could name it anything you want. However, you should name it something meaningful because this name will appear in a menu later on, and you'll want to easily remember what it meant.

7. Click on the right side of the Frames panel and look at the Property Inspector again. This time there is no frame name because you haven't given the right side of the frameset a name yet. Enter right into the Frame Name field. The Frames panel should now read left and right in faint letters. Leave the Frames panel open—you'll need it shortly.
8. Select the words **Bonsai Tools** in the left frame. Click on the arrow next to the **Target** field to access the pop-up menu. Select **right** from the menu. The word **right** should pop into the **Target** field.

9. Press **F12** to preview the page again. Click on the link. If you’re prompted again to save your files, click **Save**. This time the results should appear on the right side. You’ve just set up your first target in your first frameset. And you’re on your way to mastering frames, which is no small accomplishment!

10. Return to Dreamweaver MX and keep the files open for the next exercise.
Target Names

A further explanation of target names is in order, because in the last exercise you used only the Custom Target feature.

When you access the pop-up menu for Target, you may wonder what the terms _blank, _parent, _self, and _top mean. You created the targets right and left, and those names are in the menu because you added them. The other names, however, are part of the HTML specifications. Below you will find a chart that explains their meanings.

<table>
<thead>
<tr>
<th>Target Name</th>
<th>Significance</th>
</tr>
</thead>
<tbody>
<tr>
<td>_blank</td>
<td>Loads the link into a new browser window. This is the target to use if you want to keep someone inside your site, and show them another site at the same time. It opens a new browser window, so that two windows are on the screen at the same time—one containing your site, and the other containing the URL of the site you linked to.</td>
</tr>
<tr>
<td>_parent</td>
<td>Used when framesets are nested, to send your end user to the parent of the nested framesets. It's possible to put a frameset inside another frameset, but that's more advanced frameset building than this book covers. Frankly, we rarely use this target, because we rarely work with nested framesets.</td>
</tr>
<tr>
<td>_self</td>
<td>Used when you want the results of the link to load in the same page that the link was in. That's the default behavior of HTML anyway, so we never use this.</td>
</tr>
<tr>
<td>_top</td>
<td>Transports the end user from a frameset to a single HTML page. This breaks the frames and loads all of the results into a single page, in the same window. Use this target when you want to exit a frameset.</td>
</tr>
</tbody>
</table>
NOTE | To Scroll or Not to Scroll?

We keep harping on the fact that frames can look boxy, and you’ve already learned how to remedy this by turning off the border on the frameset. What about scrollbars, which can also make a frameset look boxed in? Scrollbars are necessary if your content is larger than the size of the frame. You can turn scrollbars off completely or allow them to appear automatically, which is the Dreamweaver MX default. We suggest you leave the program at its defaults. If the content is big enough to warrant scrollbars, they’ll appear.

Scrollbars are set in the Property Inspector.

To access the Property Inspector’s Frame Scroll options, click on the right or left region of the Frames panel. Scrollbars are set independently for each frame. It is not necessary to do this at all unless you want to force scrollbars on or off via the Scroll option.
Adding a Background Image

You've learned how to color the background of each frame, but what about adding a background image? This is similar to coloring the background of each frame, which you already did in Exercise 2. There can be unexpected alignment problems with this process, however, if the frameset clips the background image on one of the frames. In this exercise, you will learn how to set the left frame to a specific size so that it doesn't cut off the background image unexpectedly.

1. Click inside the left frame and make sure you see the text-insertion cursor blinking to the right of the linked words Bonsai Tools. Choose Modify > Page Properties.

2. Click the Browse button to the right of the Background Image field to browse to the images folder, and select bg_symbol.jpg. Click Open, and then OK in the Page Properties dialog box. The background image should appear in the left side of the frameset.

3. Click inside the frame named right.html and make sure you see the text-insertion cursor blinking, then choose Modify > Page Properties.

4. Click the Browse button to the right of the Background Image field to locate once again bg_symbol.jpg in the images folder where you just were. Click Open, and then OK. The background image should appear in the right side of the frameset.
There's just one problem. It doesn't look that great, does it? The background image has been clipped by the size of the two frames. To correct the problem, it's essential to know the dimensions of both the graphic and the frameset. The following steps walk you through this process.
5. To establish the size of the background image, click on the left.html frame again and make sure you see the blinking text-insertion cursor. Choose Modify > Page Properties again. Click on the Browse button to the right of the Background Image field to locate bg_symbol.jpg. Make sure that you check the Preview Images checkbox in the Select Image Source dialog box. Notice that the dimensions 125 x 125 appear in the Select Image Source preview window? You now know that the width of the image is 125 pixels. Click Cancel twice to return to the document window.

Why cancel? The sole purpose for doing this step was to read the dimensions of the graphic, not to actually reinsert the background image! Often, we will insert an image just to learn more about its size or downloading speed, and then cancel out of the process once the information is gathered.

Next, you’ll want to make the left column of the frameset match the size of that background image. Because the background image is 125 pixels wide, you could make the left.html column 250 pixels wide, and it would tile twice perfectly. Question is, how do you get to the information that shows the left column’s size? Frankly, it’s a bit tricky and takes some clicking around.
6. In the Frames panel (if it's not visible, go to Window > Frames), click on the outer border of the panel. Your Frames panel might already look like this before you read this step. If so, click on the left side, and then click on the outer border again.

Sometimes you have to toggle the outer border of the Frames panel on and off to get it to show the correct information settings in the Property Inspector. What's the goal of doing this? Changing your Property Inspector to show you the frameset's column size.

The goal of clicking on the outer border of the Frames panel is to change your Property Inspector so that it looks like this, which gives you access to the column value. With the left column selected in the Property Inspector, you can see that the Column setting is 150 pixels, which is the setting that you created way back in Exercise 2. You'll want to change this to accommodate the size of the background image in this exercise. The next steps walk you through this process.

MOVIE frames_settings.mov

To learn more about frames, check out frames_settings.mov located in the movies folder on the Dreamweaver MX H•O•T CD-ROM.
7. Enter the value **Column: 250** into the **Property Inspector** and press **Enter**. The left column should have just shifted a bit to the right. Things still don’t fit properly because there are more steps to follow.

8. In the **Property Inspector**, click on the right **Column** icon, at the right of the panel. Select **Units: Relative**. Now to remove the border between the two frames. Make sure the frameset borders are selected using the **Frames** panel. From the **Borders** pop-up menu, select **No**. Type **0** for the **Border Width**.

   Bingo! The background image now tiles perfectly!

9. Select **File > Save All** and press **F12** to preview in your browser.

If the directions in Exercise 4 seemed odd and/or mysterious to you, it’s because they are a little odd and mysterious! Perhaps this review will help: Clicking on the right side of the Property Inspector’s Column icon allowed you to change the settings for the right column. Choosing Relative Units makes HTML allocate to the right column whatever space is left over from the fixed-pixel left column. In Exercise 4, you wanted the left side to be fixed, but the right side to scale proportionately depending on the size of the end user’s monitor.
TIP | Specifying a Frame Size

The last exercise showed how to specify the left frame to be 250 pixels wide. Here are step-by-step directions to access the frame size settings.

1. Make sure the Frames panel is open (Window > Frames).

2. Click on the outer region of the Frames panel. Tip: You might have to click on an inner region and then an outer region to jog the Property Inspector to show the correct setting.

3. Click on the icon to the far right of the Property Inspector to select the appropriate frame. In this instance, it's the right one.

4. Enter the Column Value of your choice. You can select units in either Pixels, Percent, or Relative. See the chart on the next page for a description of each.
Units

Below is a chart that defines the choices you have when specifying a frame size in the Property Inspector:

<table>
<thead>
<tr>
<th>Units</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pixels</td>
<td>Sets the size of the selected column or row at an absolute value. This option is the best choice for a frame that should always be the same size, such as a navigation bar. If you set one of your frame regions to <strong>Pixels</strong>, all the other frames will have to yield to that size. In other words, <strong>Pixels</strong> takes priority over all other settings.</td>
</tr>
<tr>
<td>Percent</td>
<td>Specifies that the current frame take up a specified percentage of the frameset. This causes frames to dynamically resize according to the width or height the end user's browser was opened to. If you mix <strong>Pixels</strong> and <strong>Percent</strong>, <strong>Pixels</strong> will be honored first.</td>
</tr>
<tr>
<td>Relative</td>
<td>Allocates space after frames with <strong>Units</strong> set to <strong>Pixels</strong> and <strong>Percent</strong> are satisfied. These frames are designed to take up all the remaining space in the browser window.</td>
</tr>
</tbody>
</table>

NOTE | Frame Properties

What do the frame settings mean in the Property Inspector? On the following page you will find a chart to help you understand them.
### Frame Properties In Dreamweaver MX

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Frame Name</strong></td>
<td>Sets the name of the current frame so you can use targets (remember _blank, _parent, _self, and _top?) when setting up links. This name must be a single word or use underscores (my_name) or hyphens (my-name). Spaces are not allowed.</td>
</tr>
<tr>
<td><strong>Src</strong></td>
<td>Sets the source document for each frame. Enter a file name or click the folder icon to browse to and select the file. You can also open a file in a frame by clicking the cursor in the frame inside the document window and choosing File &gt; Open in Frame.</td>
</tr>
<tr>
<td><strong>Scroll</strong></td>
<td>Determines whether scrollbars appear when there is not enough room to display the content of the current frame. Most browsers default to Auto. This is a good thing, because you only want scrollbars if they are necessary. Scrollbars aren't pretty, but they are necessary when there's more content than the frameset column size can display.</td>
</tr>
<tr>
<td><strong>No Resize</strong></td>
<td>Prevents a frame from being resizable in browsers. <strong>Tip:</strong> If you turn the borders off in your frameset, end users won't be able to resize them even if the No Resize option is left off.</td>
</tr>
<tr>
<td><strong>Borders</strong></td>
<td>Controls the border of the current frame. The options are Yes, No, and Default. This choice overrides border settings defined for the frameset. It's important to set the borders to No even if you've set them to 0, because of differences between Netscape and Explorer. Netscape honors 0; Explorer honors No.</td>
</tr>
<tr>
<td><strong>Border Color</strong></td>
<td>Sets a border color for all borders adjacent to the current frame. This setting overrides the border color of the framesets. It's supported only on 4.0+ browsers, so if you choose to use it at all, we don't recommend that you make it an integral part of your design.</td>
</tr>
<tr>
<td><strong>Margin Width</strong></td>
<td>Sets in pixels the width of the left and right margins (the space between the frame border and the content). The default is that the frame border and content are aligned, so unless you want an offset, you don't need to adjust this setting.</td>
</tr>
<tr>
<td><strong>Margin Height</strong></td>
<td>Sets in pixels the height of the top and bottom margins (the space between the frame border and the content). The default is that the frame border and content are lined up, so unless you want an offset, you don't need to adjust this setting.</td>
</tr>
</tbody>
</table>
5. **Seamless Background Across Two Frames**

In the previous exercise, you learned to put the identical background image into two frames and how to set a frameset's column width. Next, you'll produce a similar exercise that uses different artwork to further alter the appearance of the frameset. In this example, the background image art was created at a size large enough to fill the entire screen (800 x 600 pixels), then sliced into two pieces, and then reassembled inside the frameset to appear as a seamless image. This technique successfully hides the unwanted boxy appearance that results so often when creating frames.

You may not realize that this page is composed of frames. That's because this frameset uses two different background images that have been cut up to appear as a single background image. You'll learn how to accomplish this technique by following the steps in this exercise.
1. Open frameset2.html from the frameset2 folder. This is similar to the document you made before, but a lot of the early steps are already completed. Click on the left frame in the document window. Next, choose Modify > Page Properties.

2. Click on the Browse button to the right of the Background Image field and browse to the images folder and then the slices folder. Select bg_left.jpg. Notice that the dimensions appear in the Image Preview of the Select Image Source window and that the width of this image is 250 pixels. Click Open, then OK.
3. Click on the right frame of the frameset and choose **Modify > Page Properties**. Select `bg_right.jpg` (from the `slices` folder you’ll find inside the `images` folder) as your background image. Notice that the dimensions appear in the **Image Preview** of the **Select Image Source** window and that this image is 850 pixels wide. Click **Open**, then **OK**.

Your screen should look funky because you haven’t set the frameset’s dimensions yet.

4. Make sure the **Frames** panel is open (**Window > Frames**), and click on the outer region (if you’ve forgotten how, check Exercise 4, Step 6) to make your **Property Inspector** display the frameset’s dimensions. Click on the left side of the **Column** icon and select **Borders: No**. Then enter **Border Width: 0**, **Column Value: 250**, and **Units: Pixels**.
5. Click on the right side of the **Column** icon, and enter **Units: Relative**.

6. Remove the frame border the same way that you did in the previous exercise.

7. Press **F12** to preview in your browser. When you are satisfied, **save** and **close** the file.

If your screen looks like this, you did everything right! If it doesn't, go back and reread all the steps (especially the part about setting the right side to Relative!) It looks like a single page with a single background, does it not? If your audience hates the way frames look, they should have no complaints with this little sleight of hand.
Frames Objects

The previous examples taught you a lot about the basics of frames. Now that you have that knowledge under your belt and understand the concepts behind frames, you will be able to fully understand the power of the Frames panel. This exercise shows you how to use it.

1. Open a new blank document.

2. Make sure the Insert panel is showing, if it is not, go to Window > Insert. Click on the Frames tab to display the frame icons on the Insert panel.

3. Click on the first icon on the left column side of the panel. This will make Dreamweaver MX create a frameset similar to the icon.

Note: This step is an alternate method to Step 3 in Exercise 1. You don’t have to choose Modify > Frameset Split Frame anymore if you use these handy objects on the Insert panel.

TIP | What Does the Blue and White Mean?

You might have noticed that the icons in the Frames Insert panel are colored in blue and white. This has significant meaning: It tells you how the different areas have been specified with regard to size. The blue areas are set to a relative size, and the white areas have been set to an exact pixel size.

What you spent several steps establishing in Exercise 4 by setting the frames to be either relative or pixel-based is accomplished automatically by using one of these frames objects from the Insert panel. This is a huge improvement in Dreamweaver MX. Don’t hate us for making you go through all those steps in Exercise 4, though. As teachers, we decided it was good for your education to appreciate the frames features in Dreamweaver MX by learning how to do it manually and painfully first. Sorry ‘bout ‘dat, but not really. Just think, “no pain, no gain.” ;-)
This is what your page should look like at this point.

4. With the frameset still selected, choose File > Save Frameset As. This works just like the procedure you learned in Exercise 1.
5. The first file you are going to save is the frameset file. It contains all of the information on how the entire structure of the page is set up. Save this file as `frameset.html` inside the `frameset3` folder.

6. The next file you are going to save is the left frame of your frameset. Click inside the left frame of the document window and choose File > Save Frame As. Save this file as `left.html` inside the `frameset3` folder.
7. The next file you are going to save is the **right frame** of your frameset. Click in the right frame of the document window and choose **File > Save Frame As**. Save this file as **right.html** inside the **frameset3** folder.

As you can see, using a frames object from the Insert panel is a pretty simple way to create a frameset. But you still need a working knowledge of framesets, so that's why we chose to wait until the end of this chapter to show you this option. Now that you know it's here, use it!

8. Close this file. You are done working with it.

Phew, this was a long chapter. Take a quick break, and then it's time to move on to the next chapter.